Back to overview
Degraded

Investigating: BrightPay Performance Issues

Jan 23 at 11:58am GMT
Affected services
BrightPay

Resolved
Jan 23 at 03:55pm GMT

Performance issues identified with BrightPay have now been resolved. We continue to monitor.

Created
Jan 23 at 11:58am GMT

Our team are currently investigating some performance issues across BrightPay.