Back to overview
Degraded
Monitoring: Performance
May 22 at 10:11am BST
Affected services
Surf Accounts Production
Resolved
May 24 at 10:25am BST
Resolved: performance issues have been resolved and remain actively monitored.
Affected services
Surf Accounts Production
Updated
May 23 at 10:35am BST
Monitoring - we are continuing to monitor performance levels across the Surf suite of products today.
Affected services
Surf Accounts Production
Created
May 22 at 10:11am BST
We are currently investigating some reports of performance degradation for some specific Surf Accounts Production functions. We will continue to monitor throughout the day.
Affected services
Surf Accounts Production