Back to overview
Resolved

Login issues

Jul 29, 2026 at 10:43am UTC
Affected services
BrightID

Resolved
Jul 29, 2026 at 12:18pm UTC

The root cause has been identified and a fix applied. Login issues have now been resolved. MFA is temporarily disabled on BrightWorkPapers.

Created
Jul 29, 2026 at 10:43am UTC

Login is currently experiencing issues. The team are investigating and are working on a fix.