Back to overview
Resolved
BrightPay - Degraded
Jul 28, 2026 at 12:17pm UTC
Affected services
BrightPay
Resolved
Jul 29, 2026 at 8:06am UTC
BrightPay UK mail delivery has resumed as normal. Apologies for the delay.
Affected services
Created
Jul 28, 2026 at 12:17pm UTC
BrightPay email functionality is currently unavailable in the UK. Our Engineering Team are investigating.
Affected services