BrightPay - Investigation Complete
Updated
Apr 2, 2026 at 10:28am UTC
The portal has been updated so that documents are now fully visible. Some issues persist with being able to download them. The team are preparing a fix.
Affected services
Updated
Apr 1, 2026 at 5:58pm UTC
The team have applied a change and are monitoring the impact. Full functionality in the portal will be re-enabled in the morning.
Affected services
Updated
Apr 1, 2026 at 4:21pm UTC
We have re-enabled the portal for employees and clients. HR Resources are currently only accessible in BrightPay, but are not available in the portals.
Affected services
Updated
Apr 1, 2026 at 3:46pm UTC
Our engineering teams have identified the root cause and are preparing mitigating steps.
Affected services
Updated
Apr 1, 2026 at 3:29pm UTC
We appreciate your patience and understanding while we continue to investigate an issue with the Employee and Client Portals.
Affected services
Created
Apr 1, 2026 at 2:06pm UTC
We are currently investigating an issue with BrightPay and have temporarily restricted some levels of access.
Affected services