Back to overview

Resolved: InformDirect

Apr 07, 2025 at 01:29pm UTC
Affected services
Inform Direct

Resolved
Apr 07, 2025 at 01:29pm UTC

The underlying InformDirect issue has now been resolved, and systems are functioning normally. We continue to monitor.