Back to overview
Degraded
Maintenance: BrightPay Online
Jan 30 at 03:52pm GMT
Affected services
BrightPay
Resolved
Jan 30 at 04:26pm GMT
Complete: BrightPay maintenance is now complete.
Affected services
BrightPay
Created
Jan 30 at 03:52pm GMT
We are currently performing an underlying system maintenance task - systems should remain unaffected during this period.
Affected services
BrightPay