Back to overview
Investigating: Microsoft Global Issues
Jul 30 at 03:55pm BST
Affected services
BrightID
BrightBooks
BrightAP
Surf Payroll
Resolved
Jul 30 at 03:55pm BST
Microsoft global issues resolved - we will continue to monitor our systems for performance and availability.
Affected services
BrightID
BrightBooks
BrightAP
Surf Payroll