Back to overview
Degraded
Investigating: Connect Issues
Sep 06 at 09:56am BST
Affected services
BrightConnect
Resolved
Sep 06 at 10:51am BST
Resolved: Intermittent issues with Connect have now been resolved. Thank you for your patience.
Affected services
BrightConnect
Created
Sep 06 at 09:56am BST
Unfortunately at present we are having intermittent issues with Connect. We are looking at this urgently and hope to have this resolved as soon as possible
Affected services
BrightConnect