Back to overview
Downtime

Investigating: Connect application downtime

Jun 12 at 12:31pm BST
Affected services
BrightConnect

Resolved
Jun 12 at 12:44pm BST

Resolved: we have now resolved the system issue impacting Connect.

Created
Jun 12 at 12:31pm BST

Investigating: we are currently investigating downtime with the Connect application. Our engineers are currently working to identify and resolve.