Back to overview
Downtime

AccountancyManager issues

Jun 02, 2023 at 08:07am UTC

Resolved
Jun 02, 2023 at 08:27am UTC

Resolved: Issues with AM are now resolved and system is functional.

Created
Jun 02, 2023 at 08:07am UTC

Investigating - We are receiving reports that AM is unavailable for some users. We are investigating this as a priority.