Back to overview
Resolved

Bright Manager currently experiencing issues

Sep 14, 2026 at 3:50pm UTC
Affected services
BrightManager

Resolved
Sep 14, 2026 at 3:50pm UTC

Some users may be experiencing degraded performance or intermittent outages.