Back to overview
Resolved

BrightPay slow down and errors

Aug 25, 2026 at 9:14am UTC
Affected services
BrightPay

Resolved
Aug 25, 2026 at 10:00am UTC

The issue was resolved. Our engineers have prepared a further fix to ensure the problem does not reoccur.

Created
Aug 25, 2026 at 9:14am UTC

BriughtPay is currently experiencing slow performance and an increase in errors. The team are investigating.